Am trying to run Latex + Emacs under DOS 5.0, and would currently seem to need long filenames. I have tried the DOSLFN driver but it prevents Emacs from running. I have 4 MB RAM in total.

Is there any smaller LFN driver? Any other solution?

MEM shows

408688 largest executable program size

without DOSLFN, and

396896 largest executable program size

with it, so DOSLFN only takes 11792 bytes, but still, Emacs does not run.

MEM shows

655360 bytes total conventional memory
640000 bytes available to MS-DOS
[...]
3407872 bytes total contiguous extended memory
0 bytes available contiguous extended memory
3341312 bytes available XMS memory
64Kb bytes High Memory Area available

and I am using GNU Emacs 19.34 on an Omnibook.

I have tried running Emacs without DOSLFN and with less memory (396K), and it works. I have also managed to free more memory (460K), yet Emacs still fails to run when DOSLFN is loaded. It fails with no output.

Edit: apparently the solution is to reinstall Emacs after loading the LFN driver. I have not yet tested this.

  • 1
    If it helps: Decades ago, I've run a TeX (including LaTeX) distribution called emtex on MS-DOS before there were long filenames, so I suppose it would work without DOSLFN. – dirkt Dec 5 at 11:26
  • I have to ask: why? I'm not saying you shouldn't be doing it, but, if your goal is simply to use Latex for type setting, why not use a modern platform? – JeremyP Dec 5 at 13:22
  • @JeremyP: clearly you have never tried a HP Omnibook. – Tomas By Dec 5 at 13:23
  • @TomasBy is that your only computer? – JeremyP Dec 5 at 15:19
  • 3
    This is retrocomputing! He doesn't need a reason! – dashnick Dec 5 at 18:27
up vote 3 down vote accepted

DOSLFN is the smallest LFN driver I’m aware of, short of built-in support in operating systems — but kernels with LFN support built-in take more memory than DOS 5. DOSLFN itself only needs 12K of memory. Since you’re trying this on an Omnibook, changing the operating system isn’t trivial anyway.

The symptoms you show suggest that Emacs is failing to start not because it doesn’t have enough memory available (it’s a 32-bit protected mode application anyway, so it only cares about conventional memory in so far as it needs some to be able to load). Presumably there’s some incompatibility between Emacs and DOSLFN, at least on MS-DOS 5 on an Omnibook...

You could try the LFNDOS driver instead; it’s available from the same location as you presumably got DOSLFN.

Alternatively, I think it should be possible to run LaTeX and Emacs under DOS with short filenames; at least, I used to, back in the nineties, before long filenames were available on FAT. The DJGPP project is careful about ensuring that “user” programs work without long filenames (they should only be required if you want to rebuild parts of DJGPP).

  • 1
    Ah, the fact that it’s an Omnibook is significant, IIRC that has DOS in ROM. Does Emacs say anything at all, or does it just fail to start? – Stephen Kitt Dec 5 at 10:27
  • Does it start when DOSLFN isn’t loaded? – Stephen Kitt Dec 5 at 10:36
  • 1
    "it should be possible to run LaTeX and Emacs under DOS with short filenames": yes, but I want some extra packages that use long names, and thought maybe installing LFN driver would be easier than changing one hundred file names and then spending a week or month sorting out the random errors. – Tomas By Dec 5 at 11:01
  • 1
    Heh, I understand ;-). I’m trying to provide a reasonably generic answer (other than the Omnibook specifics which mean it’s not useful to go into memory-management details). – Stephen Kitt Dec 5 at 11:03
  • 1
    LFNDOS does not work either. – Tomas By Dec 5 at 11:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.