7

After discovering my old Commodore 64 in the garage, I wanted to test if it still works. The power light comes on but the video connection to a modern TV is obviously an issue, as mentioned here. Well I bought this cable from ebay, and although it is red and white, it is sold as an audio/video cable, and not just audio. But I'm not picking up a signal, so either the item was misleading in its description of video, or my commodore 64 isn't working. Does anybody have experience with this cable?

A circular plug with five adjacent pins, spaced in a circle in a way that would be even were there three additional pins; attached to two (probably) 3.5mm jacks. One jack is red, and the other is white.


Thanks for everyone's contribution on this. So based on the C-64 AV jack pinout as provided by Janka, each pin was tested using a multimeter to see which pin may be connected to which colour lead, and it seems red is video and white is audio. I think this confirms Brian's suspicion that the cable is OK, and I remember basing my purchase on similar ideas. Hence it does seem most likely that there is an issue with my C64 video. I can actually hear a faint sound when I turn it on, so the audio may be OK. Of course it's difficult to say definitively without having a working C64, but currently I'm going through some options, including all those suggested by Brian.

  • Hardly to call that keyword cloud a description at all, or is it? Fastest way would be to check the wireing with a ringer. Going by the comours there's a good chance that it's just for audio anyway. – Raffzahn Dec 24 '18 at 12:19
  • Welcome to Retrocomputing Stack Exchange. Thanks for the description of your problem. It's possible that one of those cables is carrying a video signal; have you tried plugging them one by one into the yellow hole? But it could just be a misleading description. – wizzwizz4 Dec 24 '18 at 12:26
  • I would expect to see a yellow connector for video. Maybe the seller noticed that C64 uses the same DIN connector and thought it was compatible. – snips-n-snails Dec 24 '18 at 17:39
  • I have a similar cable that I use on my C64 and it works just fine. You are connecting the red plug to the yellow jack on the TV, right? – Fred Larson Jan 3 at 21:36
6

You have to check if this is the correct cable. Unfortunately, the DIN connector the C64 uses for it's A/V output is similar to the DIN connector used for tape playback/record on old audio hardware.

C-64 AV jack pinout: C-64 audio and video jack pinout

Audio Out (Pin 3) is line level (2V peak-to-peak) and Video Out (Pin 4) is composite video (either NTSC or PAL).

Pin 3 and Pin 4 of the DIN jack have to go to the center pins of the RCA jacks and Pin 2 to the outside of both jacks.

More details on the jack and its signals can be found here.

  • 1
    If the pinout of the cable is incorrect it should be a fairly simple matter to correctly rewire it since, IIRC, DIN plugs are usually easy to open. If you're really lucky you might be able to simply pull out the erroneous pins and insert them in the correct positions. If not they can simply be resoldered. The extant wire connections can be determined by buzzing it out using the "continuity" mode on a multimeter (or "resistance" mode if you don't have it). – Alex Hajnal Dec 24 '18 at 22:44
  • Just to clarify: Is that the pinout for a C-64 compatible plug? Or is that a C-64 jack pinout? – Alex Hajnal Dec 24 '18 at 22:50
  • It's the socket pinout. You can see this from the clamps shown there. The plug has pins. – Janka Dec 24 '18 at 22:53
  • That's what I reckoned. I've updated your answer to clarify that. – Alex Hajnal Dec 24 '18 at 22:55
  • 1
    @alephzero Pin 4 provides composite video (either NTSC or PAL) and pin 2 provides ground so a 5-pin plug can be sufficient for video (and audio) output. C and Y (pins 6 and 1) are only required for S-video (and are optional for SCART). source – Alex Hajnal Dec 25 '18 at 22:24
3

You most likely have a problem with your C64 video.

Based on the fact the eBay seller of the cable in question has apparently sold over 100 of them, and has a high positive feedback score, I think it's a reasonable bet that the cable is fine. I will also give you the benefit of the doubt for having tried both RCA plugs into your TV's video, since the red/white coloring gives no clue about which plug is video and which is audio.

There are a couple of common faults that you may check, since the combination of a retro computer's relatively low quality composite video signal, and a poor electrical connection, can easily conspire to defeat the sensibilities of many modern displays (e.g. HDMI flat screens that include composite video input). On the off chance you have access to an older CRT with composite input, you should also try it.

  1. Use contact cleaner on the C64's DIN plug. This may clear any corrosion inside the plug. Doing several insertions/removals of the DIN plug may also help.
  2. Take off the C64 cover and inspect the video output plug. Ensure it has a good physical and electrical connection to the C64 motherboard. Check for any cracked solder joints. Again, the goal is a good electrical connection between computer and cable.
  3. Push down firmly on all the socketed chips in the C64, which will include the VIC-II video chip. Make sure the chips are firmly seated in their sockets.
  4. Pull the VIC-II out of its socket, and clean the chip leads and the socket with contact cleaner, then re-insert it.

If none of the above fixes the video output, then you have a more serious problem that requires more serious troubleshooting. At that point, it may be most economical to just acquire a working C64. Then, you have a second, known-working C64, which is very helpful in continuing the troubleshooting.

0

You quite likely have a cable specific to certain monitors which used a pre-cursor to S-video. One RCA outputs the tone, Luminance and the other the color, Chrominance. Some cables with the same Commodore input may instead output composite video depending on what pins are connected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.