2

I am doing a fresh reinstall of Windows 98 SE on a Dell Optiplex GX1 550Mbr+. I previously had this very same version of Windows on this machine. The install works perfectly, but when I get to the login screen, I hit escape (or type in the password and press enter), and it just hangs.

I have tried:

  1. Changing hard drives
  2. Changing CD drives
  3. Changing the RAM
  4. Swapping the hard drive into another machine
  5. Removing the password

The first 3 points result in no improvement, event if I re-install from scratch.

When I swap the hard drive into another computer, I can log in just fine, so it doesn't seem to be the installation at fault.

When I remove the password (using another computer), it just hangs at the green desktop background. The mouse will move, but nothing ever loads.

CTRL + ALT + DEL will bring up the task manager, and I can restart the computer, or kill the only process (Hidserv).

Running the computer in Safe Mode works.

  • Does the computer have a network card and is it connected? The next thing after login is connecting to the network. – tofro Apr 6 at 21:09
  • It has onboard ethernet, but it is not connected. – Jonathan Apr 6 at 21:10
  • Can you try connecting it? Or disable the NIC from safe mode? – tofro Apr 6 at 21:11
  • I connected it to the offline network, to no avail. The online network does not work any better. I'm going to try disabling it from safe mode now – Jonathan Apr 6 at 21:17
  • Disabling the NIC (I did it right from the BIOS) does not work either - it still hangs right after where the login screen would be (I currently have it removed). – Jonathan Apr 6 at 21:31
2

I found the answer! Using Safe Mode, in msconf, I disabled all the options in the startup tab except:

  • Scan registry
  • Task Monitor
  • System Tray

That worked, so then I re-enabled the following:

  • Load power profile
  • Load Power Profile
  • Scheduling Agent C:\WINDOWS\SYSTEM\mstask.exe

That was still working, so I restarted again after enabling

  • Welcome
  • Hidserv

Since that did work, I finally enabled the last option in msconfig:

  • Scheduling agent mstinit.exe /firstlogon

And it worked!

I tried again on another fresh install on the same computer. This time, I only disabled hidserv, and I got the same success (Windows started normally, and I was able to re-enable hidserv in msconfig). So the problem was hidserv.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.