New answers tagged

1

Thanks for the above comments/suggestions. This in the .cfg file works to allow reading 'sector 0' :- [autoexec] mount c c:\users\roopy\source mount -t floppy b: c:\Users\roopy\Downloads\BackupDownloads\iso\DOS5and6 b: imgmount a -t floppy Dos5.img It means the code I'm testing can be run as a DOS command (temporarily) and it reads the boot sector from the ...


5

Found it! It was the CPU voltage setting, and the onboard VGA had to be disabled too, for some reason it didn't detect the VGA card. It turned out to be a little tricky. Now it works!


17

DOSBox only allows absolute sector reads from disk images, as mounted by IMGMOUNT. You can’t use interrupt 0x13, service 0x02 on drives mounted with MOUNT. (To understand that link, note that imageDiskList in DOSBox is only populated by the BOOT and IMGMOUNT commands, not by MOUNT.) The workaround is to use IMGMOUNT: imgmount -t floppy a /path/to/floppy.img


Top 50 recent answers are included