4

Simple and fast question. I want to emulate old Unix Svr4 on 86Box the network and system part is ok I have difficult with X

actually this is the sad result after olinit (start OpenLook desktop) or xinit, the screen is frozen and after 1 minute return to console

enter image description here

This is my .cfg configuration for 86Box

[General]
vid_renderer = qt_opengl3
confirm_save = 0
confirm_reset = 0
language = it-IT
confirm_exit = 0
vid_resize = 1
force_43 = 1

[Machine]
machine = 430vx
cpu_use_dynarec = 1
cpu_enable_fpu = 1
time_sync = local
cpu_family = pentium_p55c
cpu_speed = 233333333
cpu_multi = 3,5
fpu_type = internal
fpu_softfloat = 0
cpu = 12
mem_size = 65536

[Video]
gfxcard = vga

[Input devices]
mouse_type = ps2

[Sound]
fm_driver = nuked
midi_device = system_midi
midi_in_device = midi_in

[Storage controllers]
hdc = internal
cassette_mode = load

[Ports (COM & LPT)]
lpt1_device = text_prt

[Hard disks]
hdd_01_parameters = 63, 16, 1013, 0, ide
hdd_01_fn = unix.img
hdd_01_speed = ramdisk
hdd_01_ide_channel = 0:0

[Floppy and CD-ROM drives]
fdd_01_type = 525_2hd
cdrom_01_parameters = 1, atapi
cdrom_01_ide_channel = 0:1
fdd_01_image_history_01 = /home/myname/1.img
cdrom_01_type = 86BOX_CD-ROM_1.00

[Western Digital WD8013EBT #1]
base = 0280
irq = 9
ram_addr = D8000
ram_size = 16384
mac = ****

[Network]
net_01_card = wd8013ebt
net_01_link = 1
net_01_host_device = /tmp/vde.ctl
net_01_net_type = vde

[Western Digital WD8013EBT]
base = 0280
irq = 9
ram_addr = D8000
ram_size = 16384
mac =

Any suggestion? Consider this Unix System is from 1990

Xinitrc contain this line

olwm

I have also tried removing .xinitrc and editing $HOME/.olinitrc

olwm&
olfm&

But the X cursor don't move and is frozen in all cases

EDIT1: Trying with different cpu and serial mouse give same result

EDIT2: The system (where I want to start X) is Intel AT&T Unix SVr4 v 2.0

EDIT3: Using serial mouse X don't start with message: /dev/mouse no such file or directory, using PS2 mouse start but freeze

EDIT4: with the command "mouseconfig" you can setup bus or ps2 or serial mouse, actually I have tried ps2 and serial, but X still stuck now trying bus

EDIT5: if anyone want to test it, this is the guide to install Svr4 (Intel version found on archive.org, the 2.1 version on other site is incomplete, lack a lot of things like X11, networking, etc.)

a) install on raw hd on qemu, first we create it qemu-img create disk1.img 499M

b) launch the vm with this configuration qemu-system-i386 -m 16 -fda Disk\ 03\ -\ Boot\ -\ ST-506\ ESDI\ -\ Disk\ 1\ of\ 2.img -boot a -hda disk1.img

c) after the install (remind to install all packages, including the network driver) turn on 86box (but before make first boot with qemu-system-i386) with my configuration, it should works.

Some proofs

enter image description here

enter image description here

EDIT6: If only qemu support old nic ISA WDC8013...

EDIT7: Will X works on qemu?

enter image description here

No :)

13
  • 1
    Does the X cursor move? If so,.it looks like the X server is started but no clients have attached. Can you post your xinit config? Dec 26, 2023 at 16:10
  • 1
    This is how X looked right after coming up. I would suspect the X server needing a device that times out. Look in the server log. Dec 26, 2023 at 23:28
  • 2
    Can you link the Svr4 and the X Server you are using? Then we could try it ourselves. For old X servers, you usually run X -probeonly, look at the log, and start writing a config file. Then you start X manually with this config file, and once that works, then you start with xinit etc. At least some VGA driver should work, getting the mouse to work can also be "fun".
    – dirkt
    Dec 27, 2023 at 13:41
  • 1
    Total guess on my part: you say you're trying to run an OS config from 1990, but your VM is defined as cpu_family = pentium_p55c and mouse_type = ps2. I don't know if the CPU speed can cause problems, and I would be surprised if an arbitrary 1990 X config would be set up for - or even know about - PS/2 mice.
    – Lou Knee
    Dec 27, 2023 at 14:44
  • 1
    @elbarna and if you'd actually link what you are using, we could find out what that particular X server supports, and what it doesn't support. Because guessing that is a bit difficult, in absence of a working crystal ball... As long as you only tell us what you've tried and what is not working, we can't really help you.
    – dirkt
    Dec 27, 2023 at 16:35

1 Answer 1

4

Very partial answer, but I already spend entirely too much time on it, so maybe this information helps somebody else.

There are a number of collections of floppy installation disks for SVR4 available if you search, for example the "Intel Unix V R4 V2" is on archive.org.

Unfortunately, even with the information from this thread, I just cannot install it in 86Box (Version 4.0.1, on Linux, compiled from git), it always hangs on boot disk 2, even if I manage to make either a working SCSI configuration and boot from the Adaptec disk, or use the IDE one and boot with the ST-506 disk.

Same with another non-Intel variant found on abandonware sites, this one only had a single boot disk, and works with IDE, but it always errored out when doing the initial bad sector check on the harddisk.

But maybe I am just too stupid, and someone else can get it to work, or even provide an installed image with a configuration file that just runs.

The non-Intel variant actually installs fine on Virtualbox, and Virtualbox is a lot faster than 86Box. But it doesn't contain X, so I couldn't try anything. The disks with the X package from the Intel variant don't install on this variant.

The whole 86Box experience has been underwhelming so far; there are lots of models and variants, but not much information that helps in figuring out which combination could possibly work, what BIOS you get for which motherboard, etc.

The plan to get X running would have been to

  • Enable serial port to host in the emulator
  • Configure the system with a serial port
  • Read all manpages about the X server, look at the configuration file this variant uses
  • Login from the serial port, start the X server directly
  • Observe what happens, and debug; graphics seem to be working in principle
  • Directly debug the device for the mouse, in case it's the mouse hangs

But given my experience with 86Box so far, I would not be surprised if there is just something in the emulation that is not working properly, and makes everything fail.

5
  • 1
    Partial answer, but useful, I will try it.
    – elbarna
    Dec 31, 2023 at 13:27
  • Atm: i read only this message : X -logo Controlling tty is /dev/vt01
    – elbarna
    Jan 1 at 20:45
  • Sorry, I cannot debug this with bits and pieces of information from you. I need a working system in front of me, and I need to read the man pages, and I need to run strings if necessary, and I need to do all the other things to make this work. But as long as the system doesn't install for me, even with your configuration, because 86box cannot do proper harddisk/scsi emulation, and I don't have any working image provided by somebody else as it doesn't seem to work for me, I cannot do that.
    – dirkt
    Jan 2 at 12:30
  • The man pages are not available on this system, in that time were sold separately
    – elbarna
    Jan 2 at 14:35
  • To install use this trick, install on raw hd on qemu (qemu-img create disk1.img 499M) with this simple line qemu-system-i386 -m 16 -no-fd-bootchk -fda 1stfloppyimgofunix -hda disk1.img, after the install (install all including the network driver) turn on 86box (but before make first boot with qemu-system-i386) with my configuration, it should works.
    – elbarna
    Jan 2 at 14:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .