7

I own a 1999 IBM Personal Computer 300GL (Type 6275-90U). It's a Slot 1 Pentium III, Intel 440BX chipset, with a riser board for adding PCI and ISA cards and 3 PC100 DIMM memory sockets.

About 50% of the time, when I try to boot, it immediately gives either a 1-3-1 or 1-3-4 POST error beep codes, which are RAM-related as per the user manual. If I turn it off, then wait a few moments, I can usually get it to POST and boot just fine. However, sometimes, it will still tell me a lower capacity number when looking at installed RAM in the CMOS settings.

Here's what I've done to troubleshoot:

  1. Used only a single stick
  2. Swapped the stick into each DIMM slot
  3. Swapped with a known working stick and did the same
  4. Reseated the CPU
  5. Swapped the entire CPU with a known working one
  6. Reseated the power connector on the riser board
  7. Swapped the entire PSU with a known working one
  8. Reset CMOS settings to default
  9. Upgraded BIOS to what I believe was the last version
  10. Cleaned slots with compressed air and isopropyl alcohol

It's beginning to look more like a motherboard issue. Since it's difficult to source a replacement (IBM FRU 61H2347), I'm guessing that I may have no real recourse to repair this machine.

Can anyone give suggestions on what I could do to salvage this machine?

9
  • 2
    How do you know the RAM stick you swapped was working, and did it produce the same error when swapped in? Do you have a BIOS where you can set RAM timings? If yes, have you tried relaxing timings?
    – dirkt
    May 10 at 18:48
  • 1
    Your RAM may be damaged. Discard those sticks giving errors (experiment to see which) and buy replacements. May 10 at 21:52
  • 3
    It is possible for more than one part to have failed.
    – wizzwizz4
    May 10 at 23:17
  • 2
    I sometimes had a problem with dust and oxidation on the memory slots ... its a long shot but you will not break anything by trying to clean: turn everything off remove all memory modules and clean both slots and memory modules side connector with toothbrush wet in alcohol , then wait a minute till alcohol dries and put all back together and try again ... do not forget to dissipate your electric charge by touching grounded metal before doing this... Also IIRC there was a small CD ISO with bootable ram test (computing PI) not sure but looks like this is it
    – Spektre
    May 11 at 6:35
  • 2
    @NateEldredge I tried to run Memtest86 with it both cache on and off, but they both produce errors. At first, it was only about 2 errors with several passes, but not I'm getting over 700+ errors. The good news is that I was able to get a better visual inspection of the board with better lighting, and found some swollen "Chhsi" brand caps. These were part of the capacitor plague that started in 1999. I am going to replace them, and report back soon. May 11 at 15:49

1 Answer 1

18

After removing some more components, and getting under the floppy drive with some light for inspection, I found three "Chhsi"-branded capacitors that were bulging. These caps are part of the known bad ones that were a result of the capacitor plague that occurred from 1999 to 2007. The caps were 560 μF with 10 volts. They appeared to be about 10 mm × 20 mm in size. I desoldered them, and soldered on some new Panasonic ones of similar spec in their place. All the other caps seem to be either Rubycon or Nichicons, which are a lot better in quality, and didn't appear to be in bad shape, so I left them alone for now.

After that, I ran several Memtest86 passes with all slots populated, and it ran like a pro. Here are the before and afters photos in case anyone cares.

Before:

Old caps

After:

New caps

2
  • 3
    Thanks for the information!
    – knol
    May 13 at 21:49
  • 1
    For electrical contact issues, a "miracle" contact enhancer called Stabilant 22 can do wonders, although it is very expensive.
    – Armand
    Jul 26 at 5:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.