1

I was recapping my zx spectrum when after just replacing one specific capacitor it stopped working as before.

The picture has multiple horizontal lines over the entire display.

This is especially noticable with yellow, cyan and magenta as they show the 2 colour that make each up repectively.

Does anyone know how this problem can be solved?

  • 5
    Are you able to add a picture showing what you mean? – Wilson Jun 4 '18 at 10:36
  • 5
    Sounds like the preemptive recapping war has claimed another casualty. Also sounds like you were doing one cap at a time. SO, you know where the problem likely exists. Check all the obvious problems with your new cap and corresponding (de)soldering efforts. – Brian H Jun 4 '18 at 15:02
  • 1
    It would help if you added a picture. Also, please read the tour so that you're familiar with the Stack Exchange model. – wizzwizz4 Jun 4 '18 at 16:08
  • 1
    The description sounds like Hanover bars (en.wikipedia.org/wiki/Hanover_bars), and if so, the fault will be around the TV modulator circuitry. However, without a bit more detail such as which model of Spectrum or which capacitor change caused the fault, it's impossible to say for sure what the actual problem is. – pndc Jul 5 '18 at 10:01
2

If this is what is displayed when the Spectrum is powered up, then it could be showing a memory problem. Without more information, it is not easy to say.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.